Tutorial 1: Composer and Nuclear Markers
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>5</td>
</tr>
<tr>
<td>The Tissue Studio® Workflow</td>
<td>7</td>
</tr>
<tr>
<td>Load Images</td>
<td>11</td>
</tr>
<tr>
<td>Loading a Solution</td>
<td>15</td>
</tr>
<tr>
<td>Find Tissue and Background</td>
<td>17</td>
</tr>
<tr>
<td>Composer: Initialization</td>
<td>21</td>
</tr>
<tr>
<td>Composer: Training</td>
<td>23</td>
</tr>
<tr>
<td>Composer: Reclassify Region</td>
<td>27</td>
</tr>
<tr>
<td>Nucleus Detection and Classification</td>
<td>29</td>
</tr>
<tr>
<td>Export</td>
<td>33</td>
</tr>
<tr>
<td>Run and Review</td>
<td>35</td>
</tr>
</tbody>
</table>
Introduction

Welcome to Definiens Tissue Studio®.

The tutorials in this book will help you quickly get started by providing step-by-step introductions. Before you configure your first image analysis solution, we will guide you through examples and outline the overall workflow.

This PDF has been typeset as a conventional book – for best results, we recommend you print this book in color on double-sided A4 and arrange the pages in a binder.

Tissue Studio® Tutorials

Each tutorial will walk you through a Tissue Studio® workflow using a specific image analysis task. The tutorials will cover the range of image data that can be analyzed with Tissue Studio®.

The hands-on training provided by these tutorials is complemented by the Tissue Studio® User Guide where all buttons, windows and widgets and Definiens terminology are explained in detail.

1  Composer and Nuclear Markers

In this tutorial you will be introduced to the Composer technology and the configuration of the nucleus detection using brightfield IHC-stained image data. After this introductory tutorial you can proceed to any other tutorial.

2  TMAs and Membrane Markers

You will learn how to detect cores on TMA slides and perform detailed nuclear marker detection on each core. Additionally, you will get an overview of the customized export function for extracting information on a cell-by-cell basis. This tutorial also shows how to apply the configured solution in batch mode on multiple slides.

3  Metadata Import, Manual ROI Selection and Vessel Detection

You will be guided through the steps required to perform an analysis using the manual ROI detection functions of Tissue Studio® in combination with the vessel detection function. You will learn how to manually select regions of interest (ROIs) based on an initial segmentation step. The detected ROIs will be submitted to a general vessel detection that identifies vessels and classifies them by size. This tutorial also shows you how to import metadata along with your images.

4  Manual ROI Selection and Marker Area Detection

You will be guided through the steps required to perform an analysis using the manual ROI detection function of Definiens Tissue Studio® IF in combination with the Mark-
er Area Detection function. You will learn how to manually select ROIs using freehand drawing. Finally, the detected ROIs will be submitted to a general marker area detection.

5 Composer, Cell Detection and Customized Export

You will be introduced to the steps required to perform an analysis on the membrane marker information of a six-channel small image with Definiens Tissue Studio® IF. You will learn how to use Composer to separate tumor and stroma regions and then selectively use the available biomarker information to segment and classify cells and nuclei.

6 Random Sampling and Spot Detection

This tutorial introduces the ROI Correction function, which allows you, for example, to manually correct automatically detected ROIs containing over-stained regions. You will learn how to use the Random Sampling function to select only a certain proportion of an image for the analysis, to increase performance. The data included in this training module are SISH-stained tissue slides and you will be shown how to detect and classify the silver spots inside the nuclei.

7 The Stain Picker and Dual Stain Separation

A guide to the Stain Picker feature, which lets you separate any single or dual arbitrary stains from a counterstain.

8 Cell Simulation and Classification

Here we explain the Cell Simulation action, which creates a representation of a cell based on the information from the Nucleus Detection action. We will describe two of the non-nuclear simulation features – Simulate Inside Both Stains and Simulate Inside Stains Separately.
The Tissue Studio® Workflow

The Tissue Studio® workflow contains four basic elements, listed in the Workflow pane (see Figure 1): Load, Configure, Run and Review. The basic concept is simple – in the first step, you load image data and select representative sample images. In the second step, you configure an image analysis solution according to your needs. A solution defines how images will be processed. In the third step you apply the solution to a set of images. The final step is the visualization of the data obtained from your analysis.

Load

You can load individual images or entire image folders: Tissue Studio® can read generic file formats – such as TIFF or JPEG – but will also import files stored in proprietary image formats from most slide scanner manufacturers. This lets you automatically import the metadata associated with the image (such as magnification), if available. The set of imported images can collectively be saved as a Tissue Studio® workspace.

After you import images you will need to select representative sample images, which will be used to configure the image analysis solution in the second step. While you can import and analyze as many images as you like, the sample set of images can contain no more than 12 images. It is important to select images that reflect the image variation observed over the entire image set you want to analyze.

Configure

The representative subset of images is used to configure your image analysis solution – you can load and modify a preconfigured solution, or assemble an entirely new one. Solutions contain a series of action modules that specify the steps of the image analysis that will be performed.

The first of these modules is typically used to adjust general settings, such as stain information or magnification. The remaining modules fall into three different categories.

The first category contains modules used to identify regions of interest (red), the second has modules for cellular analysis (yellow) and the third includes modules for data export (blue). Image analysis solutions must be configured in this order and you will receive

Figure 1: Workflow pane with Load tab active
an error message, for example, if you try to adjust the cellular analysis before you finish configuring regions of interest.

When detecting regions of interest you can, for instance, choose between modules that distinguish tissue from background, allow manual annotation or process tissue microarrays. Alternatively you may use powerful modules employing our Composer technology. Using a learn-by-example approach they help you to identify regions of interest quickly and effectively. The modules for cellular analysis include modules for the automatic detection of nuclei, distinguishing different nuclear morphologies, detecting or modeling of cells based on either membrane or cytoplasmic markers, or for automatic detecting vessels and spot stains. The export modules allow the configuration of the quantitative and visual readouts that will be exported (see Figure 2 on page 8).

Each action module contains a fairly limited number of parameters that can be adjusted. Preview buttons provide you with immediate visual feedback on the effect of your adjustments. When you are happy with the results, you can configure the next action module. Saving the image analysis solution will store your configurations.

**Run**

To run an image analysis solution you must specify the set of images to be analyzed. This set can be as large as you like and the configured solution will be applied to all of them. Processing time depends on the size of an image, the complexity of the image analysis tasks selected and the number of Tissue Studio® engines available (which in turn depends on your Tissue Studio® package – if required, turnaround times can be reduced by purchasing additional Tissue Studio® engines). Running an analysis does not require manual interaction and large datasets can be analyzed overnight. Results are stored together with the images in the Tissue Studio® workspace. Data are stored in .csv
files, which can be opened by any statistical or spreadsheet program. Images of results can be exported to facilitate quality control.

**Review**

Tissue Studio® provides helpful tools to visualize quantitative readouts, complementing third-party data software such as Microsoft Excel®. In particular, unexpected or unusual results can be linked back to the original image data and segmentation results, making quality control straightforward and efficient.
Load Images

1. Start Definiens Tissue Studio® by selecting the Tissue Studio® portal (if you do not select a portal within three seconds, the software will open the one that was selected when you last launched the program).

2. Select the Load tab and click on the Import Folders button – the Import Folders dialog box will appear (see Figure 3).

3. Select the path Training_Tissue_Studio_3.6\1_BF_Slides_Composer_Nuclei\images and click Next.

4. Select Aperio ScanScope – with resolution as the scanner type and click Next.

5. Type a name for the workspace and browse to the location where you want to save it (use the prefix WS_ to distinguish the workspace folder from other folders in the same directory) and click Finish. For more information on the Workspace Window please refer to the Tissue Studio® User Guide). Six slide scans will be visible in the newly created workspace in the Tissue Slides folder and these can be opened by double-clicking them. You can use up to twelve images simultaneously to train the software or configure a solution.

6. Mark the first four images in the list and press the Training Data button in the Workflow window (see Figure 4 on page 12).

7. Type a project name (or keep the default) and press OK to confirm the Training Data Set Name dialog, to create a four-image project.

The project is now created within the Training Data folder in the Workspace window and the four selected images will be opened simultaneously (see Figure 5 on page 12).

Figure 3: The Import Folders dialog box
The images are mouse pancreatic tissue with pancreatic islets in dark brown (DAB) and nuclei in blue (hematoxylin). The task for these images is to separate tissue, white space and connective tissue regions, and DAB-stained structures. A sample-based training using the Definiens Composer technology will be combined in this example with a reclassification based on size (to eliminate small islets from further analysis), followed by nucleus detection within the ROIs.

To allow for rapid inspection of the images, you may activate the Whole Slide Review mode by clicking the checkbox in the lower right corner of the main
Whole Slide Review is a special viewing mode optimized for performance (see Figure 6).
Loading a Solution

1. Switch to the **Configure** tab.
2. Press the **Load Solution** button.
3. In the **Load Solution** dialog box (Figure 7), select **Composer > Nuclei (Positive/Negative)** and confirm with **OK**.

The respective actions are now assembled in the **Analysis Builder** pane (Figure 8) and you can start to configure your own analysis.

![Figure 7: The Load Solution dialog](image)

![Figure 8: Action list of the loaded solution](image)
Find Tissue and Background

1. In the left-hand sidebar, click on the **General Settings** button (an active action is indicated by a yellow frame).

2. Configure the settings according to the analysis task (**IHC Brown Chromogen** as **Stain Combination** and **Nuclear** as **Marker**).

   Move the cursor over the different widgets to display a short explanation under the **Description** heading.

3. Switch to the next action **Tissue-Background Separation**

   In this solution, the action **Tissue-Background Separation** performs an automatic segmentation into tissue and background. If results are not satisfactory — for instance you want to analyze only a subset of the original tissue slide — you can replace this action with **Preselect Region for ROI Detection**, where areas to be analyzed can be defined manually.

4. Keep the default settings and press the **Preview** button (see Figure 10 on page 18).

   You will see that the results of the segmentation are not yet satisfactory. This is because the brightness gradient of the background regions makes an automatic threshold estimation difficult. In such cases it is recommended to manually adjust the thresholds.

5. Uncheck **Use Auto-Thresholds** to display manual adjustment parameters.

6. Execute **Preview (Homogeneity)**.

   In this classification (see Figure 11 on page 18) there are far too many non-tissue parts of the image highlighted, due to artifacts in the image.

---

Figure 9: Configured General Settings action
Increase the threshold until the artifacts at the image border are ignored (here 1.0).

The resulting holes inside the tissue area can be fixed using the **Brightness Threshold** — they are only an issue if they are not entirely enclosed by the red **All Tissue** class.

Execute the Preview (Brightness).

Again you can see that darker sections of the non-tissue area are misclassified.

Lower the threshold until artifacts are significantly reduced (here 200).

Use the Preview button again to see how the combined changes affect the result.

The result is now much better (the image in Figure 11 is the Pancreas 03 pane following this step); however, there are still some small tissue pieces that we would like to eliminate.

Open the **Image Object Information** pane from the **View** menu.

Click on the smaller objects you want to re-

NOTE: The decimal point must be used as a separator, not the comma. For further information on the Homogeneity and Brightness thresholds, see the User Guide.
Find Tissue and Background

13 Choose the Tissue Min Size threshold based on the maximum Area values of the small tissue objects you want to exclude (here 600) and press Preview again.

You will see that the tiny tissue pieces or artifacts are now fused with the gray background class — Figure 12 shows before and after images for the Pancreas03 pane).

Figure 11: Example image object to be removed from the classification via Tissue Min Size (highlighted)

move to display their Area values in the Image Object Information pane.

Figure 12: Final classification after adjusting the Tissue Min Size threshold
Composer: Initialization

1. Switch to the **Composer: Initialization** action.

2. Keep the default magnification of 2x and press **Select**.

   In principle, you can select up to twelve subsets from any ROI in any image. We suggest you select one subset in each image showing a variation of tissue (pancreatic islets, connective tissue and white space).

3. Click in the red **All Tissue** class in each image to create subsets (the center of the square will be where you click the mouse pointer).

4. Click on **View Subsets** to display the selected subsets.

5. To change an already created subset click on **Deselect** and click into a subset again.

---

Figure 13: Subset selection for composer configuration
Composer: Training

1. Switch to the Composer: Training action
   
   Your subsets have already been pre-segmented at a default scale. It is important to understand that the segmentation has no influence on the final Composer result: its only purpose is to allow selection of appropriate samples. If the current segmentation does not meet this need, you can change the Segmentation Scale slider and click the Resegment button.

2. We now need to define three classes that we want to use – Islet, Tissue and White Space.

3. Click on the upper Edit Classes button in the Sample Selection pane.

4. In the opening dialog change ROI 1 to Islet, ROI 3 to Tissue and ROI 4 to White Space – you can also change the colors if preferred or use any other ROI class you may want – and confirm with OK (see Figure 15 on page 24).

Figure 14: Composer subsets with an initial segmentation, enabling convenient sample selection

TIP: Do not sample too extensively in one round; it is better to go through several rounds of sampling and learning, to get a more accurate result in less time. How long this will take will depend on the heterogeneity between the training images, the spectral diversity and difference of the ROI classes, and the level of accuracy you require.

NOTE: You must assign at least two classes before pressing the Learn button – if you don’t, an error message will appear.
5. Start sampling objects by activating one of the classes and clicking or painting on objects in any of the four images (use the zooming functions to identify adequate objects for sampling if necessary).

6. If you like, you can also enter samples by using the polygon drawing mode. To do this, select Draw Polygon from the Sample Selection Mode list.

7. If you would like a finer segmentation on an individual object, select Segment Object in the Sample Selection Mode drop-down list and click on the respective object.

8. Click the Learn button.

9. Review the classification result thoroughly by using the different viewing modes and take more samples if needed.

10. Open the scene information window using View > Scene Information in the menu bar.

   You can see that in our example, classification by the machine learning algorithm was performed with an error rate below 1%.

   When satisfied with the result of your training on the chosen subsets you may want to evaluate the result on the complete slide.

11. Press Slide Preview – be aware that this process can take a couple of minutes per slide (or even longer if you work on larger slides or higher magnifications)

   Although the result looks good, consider whether the chosen resolution is...
really necessary – lower resolutions require less processing time

12 To repeat the analysis at a lower magnification, return to the action Composer: Initialization and move the Magnification slider to 0.5 (or type 0.5 into the panel and press the Return key).

13 Confirm the opening dialog box with OK; execute the Preview button, which will become active.

The resolution is now low enough to perform the Composer: Training action on the entire slides and not on subsets anymore.

14 Move to the action Composer: Training.

15 Select samples and click Learn until you are satisfied with the result, perhaps paying attention that the lymph nodes (dark blue) will be marked as Tissue and not as Islet.

You should find that, even though we have reduced the magnification dramatically (and reduced the processing time), the ROI detection is still as accurate as before.
Figure 19: Slide preview of the Composer: Training action

Figure 20: Classification and slide preview at 0.5x magnification
Composer: Reclassify Region

In this step, we will clean up the classification by removing very small objects. As we are only interested in the analysis of tumor islets, we can eliminate small islets at this stage. In the Image Object Information pane you can define a size threshold for objects you would like to keep for further analysis (here 100,000 µm²).

1. To add more actions, press the + button in the red vertical bar on the left-hand side of the list.

2. The Add Actions dialog will open. Select Composer: Reclassify Region, press Add and close the dialog again (you can use the arrows on the right to change the position of actions and the + and – buttons to add or remove them).

3. Select All Composer Classes as the Source Class. Select Best Neighbor as the Target Class.

4. Activate the Use Condition checkbox and click on the ellipsis at the right side of the Feature field.

5. The Select Single Feature dialog will open. In the directory tree, navigate to Object Features > Geometry > Extent > Area and confirm with OK.

6. Ensure the Operator is < and enter 100000 in the Value field.

7. Press the Reclassify button.

Any object (from all Composer classes) that meets the condition — smaller than 100,000 µm² — becomes fused with its ‘best neighbor’ object (the object sharing the longest common border).

NOTE: It is a matter of opinion which islets are considered normal (or whether these tissue samples contain any healthy DAB area at all). Please treat this as a training exercise designed to introduce you to the main functions of Tissue Studio, rather than a research project.

Figure 21: Results for Composer: Reclassify Region, eliminating objects less than 100,000 µm²
Nucleus Detection and Classification

To improve performance, the ROI detection has been performed on a downscaled image. To configure the nucleus analysis, up to twelve different subsets can be selected which will be displayed at a magnification accurate enough to identify nuclei.

1. Switch to the action **Initialize Cellular Analysis**.

2. Keep only the class *Islet* selected – an active ROI is signified by a gray tickbox on the button (see Figure 22). Set the **Magnification** to 10x.

3. Click on the button **Select**.

   The system keeps only the chosen *Islet* class as available for subset selection (Figure 23, left). You can now select up to twelve different subsets on any of the images to configure the downstream analysis. The more subsets you choose the longer the calibration previews for any subsequent actions will take. It is therefore recommended to select the fewest number of subsets that give you satisfactory results.

4. Click into the ROI class and create four subsets (they will be created around the pixel you have clicked), one in each available image.

5. Click **View Subsets** and check the selected regions (Figure 23, right).

6. Press the **Deselect** button and click into a subset you would like to delete or change.

7. Change to **Nucleus Detection** when you are satisfied with the subset selection.

8. Press **Preview Threshold(s)**, keeping the default settings.

---

Figure 22: Settings for subset selection

Figure 23: **Left**: ROIs available for subset selection in Pancreas 03 slide with the ‘islet class’. **Right**: Subset of a selected ‘islet’ class
The resulting classification should cover both the negative (blue) and the positive (brown) nucleus regions generously. Any pixels not covered by either of the two classes will not be considered in the later nucleus detection step. The **Hematoxylin Threshold** needs to be set to a value that excludes most of the non-nuclear hematoxylin-stained regions.

9. Change the **Hematoxylin Threshold** and **IHC Threshold** and press **Preview Threshold(s)** again until you obtain a satisfying result (here 0.3 and 0.4).

10. Activate **Select Samples** and click on some objects that are of a size typical of nuclei, or set the threshold manually: 45 in this example (see Figure 24, left).

You will see that the quality of the detected nuclei greatly depends on the image data quality, for example the stain characteristics and whether the image is in focus.

11. To further sub-classify the nuclei, switch to the **Nucleus Classification** action.

You can define four different nucleus populations based on their IHC marker intensity (low, medium and high), optical density (low, medium and high) or their size (small, medium and large). This applies only for nucleus-positive objects.
12 Make sure IHC Marker Intensity is selected.

13 Adjust the sliders according to your preferences and click Preview.

14 Repeat this process until you reach the intended result (see Figure 24 on page 30).

15 Open the Image Object Table from the View menu.

16 Double-click into the window to open the Configure Image Object Table dialog (see Figure 25 on page 30).

17 Click on Select Classes and move all nucleus classes to the right pane by clicking on them. Confirm with OK.

18 Click on Select Feature and, in the directory tree, go to Object Features > Layer Values > Mean > Brown Chromogen Intensity.

19 Double-click on the feature to move it to the Selected pane and confirm with OK.

20 Close the dialog with OK.

You get now a clear review of the available objects in the active window and also their feature values.

As objects and table are linked, you can click on any object to highlight it in the display and vice versa (for more details of the Image Object Table please refer to the Tissue Studio® User Guide).
Export

The default export takes screenshots with the classification results of the images and creates result files in .csv format, with all information about the identified nucleus objects, including stain intensity and number.

1. Switch to the Default Export action.

2. Choose the types of screenshots you want to retrieve in the drop-down menu and make sure the Statistics and Statistics Per Slide checkboxes are selected.

3. Click on the Save Solution button and browse to the location where you want to store the solution.

TIP: If you want to reuse the solution, we recommend storing it under C:\ProgramData\Definiens\TissueStudio\Data\Solutions. This way it is directly accessible via the Load Solution button.
Figure 27: Analysis progress visualized in the Workspace window
Run and Review

When you run the analysis, a read-only .dax file of the solution with the date and time of the analysis will be stored in the results folder.

1. Switch to the Run tab.

2. In the Workspace window, click on the folder Tissue Slides to display the image list.

3. Mark any number of images (but not the training data set) you want to submit to batch analysis and click Analyze Selected Images or simply click Analyze All Images if you would like to get results for all images in the workspace.

You can now follow the status of the analysis in the Workspace window (see Figure 27) – projects will switch from created to waiting to processing and finally to processed — or in the Job Scheduler (for information on how to use the Job Scheduler, refer to the Definiens XD Installation and Administration Guide).

4. When the analysis is finished, switch to the Review tab and click on the Open Results Folder button.

   Here you will find all exported results (screenshots, statistics and solution .dax file).

5. To visualize the results as a heat map, go to View > Review Heat Map

6. The first drop-down box in the Review Heat Map is Thumbnails. Change this to WholeSlideExport – this will activate all other drop-down boxes. The box below this lets you change the size of the heat map squares; in this example we have used Large Squares

7. In Level, select NucleusLevel, and select All Classes in the box to its right. In this example we will select Brown Chromogen Intensity as the Feature. The final drop-down box lets you choose statistical operators – in this example choose Mean.

   All the settings outlined here are shown in (Figure 28 on page 36)

   The Review Heat Map offers a quick way to visualize any given feature. You can adjust the transparency of the heat map using the vertical slider; additionally the bottom color bar lets you adjust the values for minimum and maximum at either end of the scale

---

1 WholeSlideExport is the default name of the Definiens Result Container (DRC). DRC is a format used by Definiens products to store analysis results. For a typical Tissue Studio® user, it is not necessary to understand this specification, but further information is available in the Tissue Studio® User Guide
8 Click the checkbox at the bottom right of Tissue Studio® to activate the Whole Slide Review viewer.

Figure 29 on page 37 shows a feature displayed in the heat map in Whole Slide Review mode.

**TIP:** You can add additional features to your Whole Slide Viewer by right-clicking in the viewer. From the context menu, you can turn on options such as a scale bar, magnifier and legend.
Figure 29: Slide displayed in Whole Slide Review Mode. The Review Heat Map displays Optical Density of Islet objects on TissueLevel.